]> git.pld-linux.org Git - packages/perl-Unicode-Map8.git/blob - perl-Unicode-Map8.spec
perl 5.38.0 rebuild
[packages/perl-Unicode-Map8.git] / perl-Unicode-Map8.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    Map8
7 Summary:        Unicode::Map8 - mapping table between 8-bit chars and Unicode
8 Summary(pl.UTF-8):      Unicode::Map8 - tabela odwzorowująca między znakami 8-bitowymi a Unikodem
9 Name:           perl-Unicode-Map8
10 Version:        0.13
11 Release:        17
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Unicode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fc93a37cabcae488bd95ca07bf5c919e
17 Patch0:         %{name}-types.patch
18 URL:            https://metacpan.org/dist/Unicode-Map8
19 BuildRequires:  perl-Unicode-String >= 2.00
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Unicode::Map8 class implement efficient mapping tables between
27 8-bit character sets and 16 bit character sets like Unicode. The
28 tables are efficient both in terms of space allocated and translation
29 speed. The 16-bit strings is assumed to use network byte order.
30
31 %description -l pl.UTF-8
32 Klasa Unicode::Map8 implementuje wydajne tablice odwzorowujące
33 pomiędzy 8-bitowymi zestawami znaków a 16-bitowymi zestawami takimi
34 jak Unikod. Tablice są wydajne zarówno jeśli chodzi o ilość
35 przydzielonego miejsca, jak i szybkość konwersji. Zakłada się, że
36 łańcuchy 16-bitowe używają sieciowej kolejności bajtów w słowie.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57 install {diff_iso,make*maps,map8_*} \
58         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README rfc1345.txt
66 %attr(755,root,root) %{_bindir}/umap
67 %{perl_vendorarch}/Unicode/Map8.pm
68 %{perl_vendorarch}/Unicode/Map8
69 %dir %{perl_vendorarch}/auto/Unicode/Map8
70 %attr(755,root,root) %{perl_vendorarch}/auto/Unicode/Map8/Map8.so
71 %{_mandir}/man1/umap.1p*
72 %{_mandir}/man3/Unicode::Map8.3pm*
73 %dir %{_examplesdir}/%{name}-%{version}
74 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.089227 seconds and 4 git commands to generate.