]> git.pld-linux.org Git - packages/perl-Unicode-LineBreak.git/blob - perl-Unicode-LineBreak.spec
perl 5.38.0 rebuild
[packages/perl-Unicode-LineBreak.git] / perl-Unicode-LineBreak.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    LineBreak
7 Summary:        Unicode::LineBreak - UAX #14 Unicode Line Breaking Algorithm
8 Summary(pl.UTF-8):      Unicode::LineBreak - algorytm łamiania linii w Unikodzie UAX #14
9 Name:           perl-Unicode-LineBreak
10 Version:        2019.001
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Unicode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  003d6da7a13700e069afed9238c864b9
17 URL:            https://metacpan.org/dist/Unicode-LineBreak
18 BuildRequires:  libthai-devel >= 0.1.9
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.26
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 BuildRequires:  sombok-devel >= 2.4.0
25 BuildRequires:  sombok-devel < 3
26 %if %{with tests}
27 BuildRequires:  perl-Encode >= 1:1.98
28 BuildRequires:  perl-MIME-Charset >= 1.006.2
29 BuildRequires:  perl-Test-Simple >= 0.45
30 %endif
31 Requires:       sombok >= 2.4.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Unicode::LineBreak performs Line Breaking Algorithm described in
36 Unicode Standard Annex #14 [UAX #14]. East_Asian_Width informative
37 property defined by Annex #11 [UAX #11] will be concerned to determine
38 breaking positions.
39
40 %description -l pl.UTF-8
41 Unicode::LineBreak wykonuje algorytm łamania linii opisany w
42 dokumencie Unicode Standard Annex #14 (UAX #14). Przy określaniu
43 miejsc łamania brana jest pod uwagę własność informacyjna
44 East_Asian_Width zdefiniowana w dokumencie Annex #11 (UAX #11).
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Unicode/*.pod
65 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/POD2/JA/Text/*.pod
66 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/POD2/JA/Unicode/*.pod
67
68 install -d $RPM_BUILD_ROOT%{_mandir}/ja/man3
69 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/POD2::JA::Text::LineFold.3pm $RPM_BUILD_ROOT%{_mandir}/ja/man3/Text::LineFold.3pm
70 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/POD2::JA::Unicode::GCString.3pm $RPM_BUILD_ROOT%{_mandir}/ja/man3/Unicode::GCString.3pm
71 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/POD2::JA::Unicode::LineBreak.3pm $RPM_BUILD_ROOT%{_mandir}/ja/man3/Unicode::LineBreak.3pm
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %dir %{perl_vendorarch}/auto/Unicode/LineBreak
80 %attr(755,root,root) %{perl_vendorarch}/auto/Unicode/LineBreak/LineBreak.so
81 %{perl_vendorarch}/Text/LineFold.pm
82 %{perl_vendorarch}/Unicode/GCString.pm
83 %{perl_vendorarch}/Unicode/LineBreak.pm
84 %dir %{perl_vendorarch}/Unicode/LineBreak
85 %{perl_vendorarch}/Unicode/LineBreak/Constants.pm
86 %{_mandir}/man3/Text::LineFold.3pm*
87 %{_mandir}/man3/Unicode::GCString.3pm*
88 %{_mandir}/man3/Unicode::LineBreak.3pm*
89 %lang(ja) %{_mandir}/ja/man3/Text::LineFold.3pm*
90 %lang(ja) %{_mandir}/ja/man3/Unicode::GCString.3pm*
91 %lang(ja) %{_mandir}/ja/man3/Unicode::LineBreak.3pm*
This page took 0.125616 seconds and 4 git commands to generate.