]> git.pld-linux.org Git - packages/perl-UNIVERSAL-exports.git/blob - perl-UNIVERSAL-exports.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-UNIVERSAL-exports.git] / perl-UNIVERSAL-exports.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    UNIVERSAL
6 %define         pnam    exports
7 Summary:        UNIVERSAL::exports - lightweight, universal exporting of variables
8 Summary(pl.UTF-8):      UNIVERSAL::exports - lekkie, uniwersalne eksportowanie zmiennych
9 Name:           perl-UNIVERSAL-exports
10 Version:        0.05
11 Release:        1
12 License:        unknown
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  4378f0e385c47829584486468414fde9
16 URL:            http://search.cpan.org/dist/UNIVERSAL-exports/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Exporter-Lite >= 0.01
21 %endif
22 Requires:       perl-UNIVERSAL-require
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is an alternative to Exporter intended to provide a universal,
28 lightweight subset of its functionality. It uses Exporter::Lite, so
29 look there for details.
30
31 %description -l pl.UTF-8
32 Ten moduł jest alternatywą dla Exportera mającą udostępnić
33 uniwersalny, lekki podzbiór jego funkcjonalności. Używa modułu
34 Exporter::Lite, z którego można poznać więcej szczegółów.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 # use from perl-UNIVERSAL-require
53 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/%{pdir}/require.pm
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/%{pdir}/exports.pm
62 %{_mandir}/man3/*
This page took 0.075969 seconds and 4 git commands to generate.