]> git.pld-linux.org Git - packages/perl-Type-Tiny.git/blob - perl-Type-Tiny.spec
Up to 1.016010
[packages/perl-Type-Tiny.git] / perl-Type-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Type
6 %define         pnam    Tiny
7 Summary:        Type::Tiny - tiny, yet Moo(se)-compatible type constraint
8 Summary(pl.UTF-8):      Type::Tiny - mały, ale zgodny z Moo(se) moduł ograniczeń typów
9 Name:           perl-Type-Tiny
10 Version:        1.016010
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/T/TO/TOBYINK/Type-Tiny-%{version}.tar.gz
16 # Source0-md5:  7e235af96b3a154307e5f1667fd85d05
17 URL:            https://metacpan.org/dist/Type-Tiny
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Exporter-Tiny >= 1.000
24 BuildRequires:  perl-Test-Simple >= 0.96
25 %endif
26 Conflicts:      perl-Kavorka <= 0.013
27 Conflicts:      perl-Types-ReadOnly <= 0.001
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Type::Tiny is a tiny class for creating Moose-like type constraint
33 objects which are compatible with Moo, Moose and Mouse.
34
35 %description -l pl.UTF-8
36 Type::Tiny to mała klasa do tworzenia obiektów ograniczeń typów w
37 stylu Moose, będących zgodnych z Moo, Moose i Mouse.
38
39 %package -n perl-Reply-Plugin-TypeTiny
40 Summary:        Reply::Plugin::TypeTiny - improved type constraint exceptions in Reply
41 Summary(pl.UTF-8):      Reply::Plugin::TypeTiny - ulepszone wyjątki z ograniczeniami typów w Reply
42 Group:          Development/Languages/Perl
43 Requires:       %{name} = %{version}-%{release}
44
45 %description -n perl-Reply-Plugin-TypeTiny
46 This is a small plugin to improve error messages in Reply.
47
48 %description -n perl-Reply-Plugin-TypeTiny -l pl.UTF-8
49 Mała wtyczka poprawiająca komunikaty błędów w Reply.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} pure_install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc COPYRIGHT CREDITS Changes NEWS README
76 %{perl_vendorlib}/Devel/TypeTiny
77 %{perl_vendorlib}/Error/TypeTiny.pm
78 %{perl_vendorlib}/Error/TypeTiny
79 %{perl_vendorlib}/Eval/TypeTiny.pm
80 %dir %{perl_vendorlib}/Eval/TypeTiny
81 %{perl_vendorlib}/Eval/TypeTiny/CodeAccumulator.pm
82 %{perl_vendorlib}/Test/TypeTiny.pm
83 %{perl_vendorlib}/Type
84 %{perl_vendorlib}/Types
85 %{_mandir}/man3/Devel::TypeTiny::*.3*
86 %{_mandir}/man3/Error::TypeTiny*.3*
87 %{_mandir}/man3/Eval::TypeTiny.3*
88 %{_mandir}/man3/Eval::TypeTiny::CodeAccumulator.3*
89 %{_mandir}/man3/Test::TypeTiny.3*
90 %{_mandir}/man3/Type::*.3*
91 %{_mandir}/man3/Types::*.3*
92 %{_examplesdir}/%{name}-%{version}
93
94 %files -n perl-Reply-Plugin-TypeTiny
95 %defattr(644,root,root,755)
96 %{perl_vendorlib}/Reply/Plugin/TypeTiny.pm
97 %{_mandir}/man3/Reply::Plugin::TypeTiny.3*
This page took 0.133626 seconds and 4 git commands to generate.