]> git.pld-linux.org Git - packages/perl-Text-vCard.git/blob - perl-Text-vCard.spec
- updated BRs
[packages/perl-Text-vCard.git] / perl-Text-vCard.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define         pdir    Text
7 %define         pnam    vCard
8 Summary:        Text::vCard - module to edit and create a single vCard (RFC 2426)
9 Summary(pl.UTF-8):      Text::vCard - moduł do edycji i tworzenia pojedynczych vCardów (RFC 2426)
10 Name:           perl-Text-vCard
11 Version:        3.09
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d23c610e2159b7d4034275f2bfe27704
18 URL:            http://search.cpan.org/dist/Text-vCard/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-Class-Accessor-Chained
23 BuildRequires:  perl-Directory-Scratch
24 BuildRequires:  perl-File-Slurp
25 BuildRequires:  perl-Moo
26 BuildRequires:  perl-Path-Tiny
27 BuildRequires:  perl-Test-Differences
28 BuildRequires:  perl-Test-Most
29 BuildRequires:  perl-Text-vFile-asData
30 BuildRequires:  perl-Unicode-LineBreak
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description 
36 This Perl module implements interface for both single vcard
37 (Text::vCard) and addressbook (Text::vCard::Addressbook). vCard is an
38 electronic business card. You will find that many applications (Apple
39 Address Book, MS Outlook, Evolution etc) can export and import vCards.
40 This package has been developed based on RFC 2426.  
41
42 %description -l pl.UTF-8
43 Ten moduł Perla implementuje interfejs do pojedynczych vcardów
44 (Text::vCard) oraz książek adresowych (Text::vCard::Addressbook).
45 vCard to elektroniczna wizytówka. Jest wiele aplikacji (Apple Address
46 Book, MS Outlook, Evolution itp.) potrafiących eksportować i
47 importować vCardy. Ten pakiet został stworzony w oparciu o RFC 2426.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %{perl_vendorlib}/vCard.pm
73 %{perl_vendorlib}/vCard
74 %{perl_vendorlib}/Text/vCard.pm
75 %{perl_vendorlib}/Text/vCard
76 %{_mandir}/man3/*
This page took 0.135029 seconds and 4 git commands to generate.