]> git.pld-linux.org Git - packages/perl-Text-WordDiff.git/blob - perl-Text-WordDiff.spec
- initial
[packages/perl-Text-WordDiff.git] / perl-Text-WordDiff.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Text
6 %define         pnam    WordDiff
7 Summary:        Track changes between documents
8 Name:           perl-Text-WordDiff
9 Version:        0.09
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  2a9db19fbb99a5520d2e8281eee6c750
16 # generic URL, check or change before uncommenting
17 #URL:           https://metacpan.org/release/Text-WordDiff
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Algorithm-Diff >= 1.19
24 BuildRequires:  perl-HTML-Parser
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module is a variation on the lovely Text::Diff module. Rather
31 than generating traditional line-oriented diffs, however, it generates
32 word-oriented diffs. This can be useful for tracking changes in
33 narrative documents or documents with very long lines.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Build.PL \
40         destdir=$RPM_BUILD_ROOT \
41         installdirs=vendor
42 ./Build
43
44 %{?with_tests:./Build test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 ./Build install
50
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %{perl_vendorlib}/Text/*.pm
61 %{perl_vendorlib}/Text/WordDiff
62 %{_mandir}/man3/Text::WordDiff*
63 %{_examplesdir}/%{name}-%{version}
This page took 0.11055 seconds and 4 git commands to generate.