]> git.pld-linux.org Git - packages/perl-Text-VimColor.git/blob - perl-Text-VimColor.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Text-VimColor.git] / perl-Text-VimColor.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Text
6 %define         pnam    VimColor
7 Summary:        Text::VimColor - syntax color text in HTML or XML using Vim
8 Summary(pl.UTF-8):      Text::VimColor - kolorowanie składni tekstu w HTML-u lub XML-u przy użyciu Vima
9 Name:           perl-Text-VimColor
10 Version:        0.11
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  268fb3f630b463fcec528d798dcf77c3
17 URL:            http://search.cpan.org/dist/Text-VimColor/
18 %if %{with tests}
19 BuildRequires:  perl-Path-Class
20 BuildRequires:  vim
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module tries to markup text files according to their syntax. It
29 can be used to produce web pages with pretty-printed colourful source
30 code samples. It can produce output in the following formats:
31 - HTML Valid XHTML 1.0, with the exact colouring and style left to a
32   CSS stylesheet
33 - XML Pieces of text are marked with XML elements in a simple
34   vocabulary, which can be converted to other formats, for example,
35   using XSLT
36 - Perl array A simple Perl data structure, so that Perl code can be
37   used to turn it into whatever is needed This module works by running
38   the Vim text editor and getting it to apply its excellent syntax
39   highlighting (aka 'font-locking') to an input file, and mark pieces of
40   text according to whether it thinks they are comments, keywords,
41   strings, etc.
42
43 %description -l pl.UTF-8
44 Ten moduł próbuje oznaczyć pliki tekstowe zgodnie z ich składnią. Może
45 być używany do tworzenia stron WWW z ładnie wydrukowanymi, kolorowymi
46 przykładami kodu źródłowego. Moduł może tworzyć wynik w następujących
47 formatach:
48 - HTML - poprawny XHTML 1.0, z dokładnym kolorowaniem i stylem
49   pozostawionym dla arkusza CSS
50 - XML - fragmenty tekstu oznaczane elementami XML-a z prostym
51   słownictwem; można to skonwertować do innych formatów, na przykład
52   przy użyciu XSLT
53 - tablica perlowa - prosta struktura danych w Perlu, dzięki czemu
54   można użyć perlowego kodu do przekształcenia jej w co tylko potrzeba.
55   Ten moduł działa poprzez uruchomienie edytora tekstu Vim i zmuszenie
56   go do zastosowania swojego świetnego podświetlania składni (znanego
57   także jako 'font-locking') dla pliku wejściowego oraz oznaczenia
58   fragmentów tekstu zależnie od tego, czy uważa je za komentarze, słowa
59   kluczowe, łańcuchy itp.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63
64 %build
65 %{__perl} Makefile.PL \
66         INSTALLDIRS=vendor
67 %{__make}
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc ChangeLog README
83 %attr(755,root,root) %{_bindir}/*
84 %{perl_vendorlib}/Text/*
85 %{_mandir}/man3/*
86 %{_mandir}/man1/*
This page took 0.0663280000000001 seconds and 3 git commands to generate.