]> git.pld-linux.org Git - packages/perl-Text-Unidecode.git/blob - perl-Text-Unidecode.spec
- BR rpm-build-macros -> rpmbuild(macros)
[packages/perl-Text-Unidecode.git] / perl-Text-Unidecode.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Text
6 %define         pnam    Unidecode
7 Summary:        Text::Unidecode -- US-ASCII transliterations of Unicode text
8 Summary(pl.UTF-8):      Text::Unidecode - transliteracje US-ASCII dla tekstu Unicode
9 Name:           perl-Text-Unidecode
10 Version:        1.30
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://cpan.metacpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  31cca8505bd74ed9d8036cdc84c808ca
17 URL:            https://metacpan.org/release/Text-Unidecode
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpmbuild(macros) >= 1.737
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # avoid extremely long provides list
25 %define         _noautoprov_perl        Text::Unidecode::x..
26
27 %description
28 Text::Unidecode provides a function, unidecode(...) that takes Unicode
29 data and tries to represent it in US-ASCII characters (i.e., the
30 universally displayable characters between 0x00 and 0x7F). The
31 representation is almost always an attempt at transliteration -- i.e.,
32 conveying, in Roman letters, the pronunciation expressed by the text
33 in some other writing system.
34
35 %description -l pl.UTF-8
36 Text::Unidecode udostępnia funkcje unidecode(...) przyjmującą dane
37 zakodowane w Unicode i próbującą stworzyć ich reprezentację przy
38 użyciu znaków US-ASCII (czyli uniwersalnych znaków zdatnych do
39 wyświetlenia, o kodach od 0x00 do 0x7F). Reprezentacja jest prawie
40 zawsze próbą transliteracji - czyli przybliżeniem znakami łacińskimi
41 wymowy tekstu wyrażonego w innym systemie pisma.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog README TODO.txt
65 %{perl_vendorlib}/Text/Unidecode.pm
66 %{perl_vendorlib}/Text/Unidecode
67 %{_mandir}/man3/Text::Unidecode.3pm*
This page took 0.122636 seconds and 4 git commands to generate.