]> git.pld-linux.org Git - packages/perl-Text-PDF.git/blob - perl-Text-PDF.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Text-PDF.git] / perl-Text-PDF.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Text
6 %define         pnam    PDF
7 Summary:        Text::PDF perl module
8 Summary(pl.UTF-8):      Moduł perla Text::PDF
9 %define         base_version    0.29
10 Name:           perl-Text-PDF
11 Version:        %{base_version}a
12 Release:        1
13 # one module mentions License=Artistic
14 License:        Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2fdf4c3170e53a083715888237914a9b
18 Patch0:         %{name}-fix.patch
19 URL:            http://search.cpan.org/dist/Text-PDF/
20 BuildRequires:  perl-Compress-Zlib
21 BuildRequires:  perl-Font-TTF
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Text::PDF - PDF manipulation module.
29
30 %description -l pl.UTF-8
31 Text::PDF umożliwia operowanie na plikach PDF.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{base_version}
35 %patch0 -p1
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc *txt lib/Text/PDF/changes
56 %attr(755,root,root) %{_bindir}/*
57 %{perl_vendorlib}/Text/PDF.pm
58 %dir %{perl_vendorlib}/Text/PDF
59 %{perl_vendorlib}/Text/PDF/*.pm
60 %{_mandir}/man3/*
This page took 0.083707 seconds and 3 git commands to generate.