]> git.pld-linux.org Git - packages/perl-Text-BibTeX.git/blob - perl-Text-BibTeX.spec
perl 5.38.0 rebuild
[packages/perl-Text-BibTeX.git] / perl-Text-BibTeX.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Text
6 %define         pnam    BibTeX
7 Summary:        Text::BibTeX - Perl library for reading, parsing and processing BibTeX files
8 Summary(pl.UTF-8):      Text::BibTeX - biblioteka Perla do odczytu, analizy i przetwarzania plików BibTeXa
9 Name:           perl-Text-BibTeX
10 Version:        0.88
11 Release:        7
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  361aad5cf400764e35d1ade3b609bb60
17 Patch0:         %{name}-mansect.patch
18 Patch1:         %{name}-libdir.patch
19 URL:            http://www.gerg.ca/software/btOOL/
20 BuildRequires:  perl-Capture-Tiny >= 0.06
21 BuildRequires:  perl-Config-AutoConf >= 0.16
22 BuildRequires:  perl-ExtUtils-CBuilder >= 0.27
23 BuildRequires:  perl-ExtUtils-LibBuilder >= 0.02
24 BuildRequires:  perl-Module-Build >= 0.3603
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 %if %{with tests}
28 BuildRequires:  perl-Scalar-List-Utils >= 1.42
29 BuildRequires:  perl-Unicode-Normalize
30 %endif
31 Requires:       btparse = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Text::BibTeX is a Perl library for reading, parsing, and processing
36 BibTeX files. It is the Perl half of btOOL, a pair of libraries for
37 dealing with BibTeX data.
38
39 %description -l pl.UTF-8
40 Text::BibTeX to biblioteka Perla do odczytu, analizy i przetwarzania
41 plików BibTeXa. Jest to perlowa połowa projektu btOOL - pary bibliotek
42 do obsługi danych BibTeXa.
43
44 %package -n btparse
45 Summary:        C library to parse BibTeX files
46 Summary(pl.UTF-8):      Biblioteka C do analizy plików BibTeXa
47 Group:          Libraries
48
49 %description -n btparse
50 btparse is the C component of btOOL, a pair of libraries for parsing
51 and processing BibTeX files. Its primary use is as the back-end to
52 Text::BibTeX library for Perl (the other half of btOOL), but there's
53 nothing to prevent you from writing C programs using btparse - or from
54 writing extensions to other high-level languages using btparse as a
55 back-end.
56
57 %description -n btparse -l pl.UTF-8
58 btparse to część C narzędzia btOOL - pary bibliotek do analizy i
59 przetwarzania plików BibTeX. Głównym zastosowaniem jest backend dla
60 biblioteki Text::BibTeX dla Perla (drugiej połówki narzędzia btOOL),
61 ale nic nie stoi na przeszkodzie pisaniu programów w C
62 wykorzystujących btparse albo rozszerzeń dla innych wysokopoziomowych
63 języków z wykorzystaniem btparse jako backendu.
64
65 %package -n btparse-devel
66 Summary:        Header files for btparse library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki btparse
68 Group:          Development/Libraries
69 Requires:       btparse = %{version}-%{release}
70 Obsoletes:      btparse-static < %{version}
71
72 %description -n btparse-devel
73 Header files for btparse library.
74
75 %description -n btparse-devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki btparse.
77
78 %prep
79 %setup -q -n %{pdir}-%{pnam}-%{version}
80 %patch0 -p1
81 %patch1 -p1
82
83 %build
84 LIBDIR=%{_libdir} \
85 %{__perl} Build.PL \
86         --config cc="%{__cc}" \
87         --config optimize="%{rpmcflags}" \
88         installdirs=vendor
89 ./Build
90
91 %{?with_tests:./Build test}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 ./Build install \
97         destdir=$RPM_BUILD_ROOT
98
99 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Text/BibTeX/BibTeX.bs
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -n btparse -p /sbin/ldconfig
105 %postun -n btparse -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc Changes README
110 %{perl_vendorarch}/Text/BibTeX.pm
111 %{perl_vendorarch}/Text/BibTeX
112 %dir %{perl_vendorarch}/auto/Text/BibTeX
113 %attr(755,root,root) %{perl_vendorarch}/auto/Text/BibTeX/BibTeX.so
114 %{_mandir}/man3/Text::BibTeX.3pm*
115 %{_mandir}/man3/Text::BibTeX::*.3pm*
116
117 %files -n btparse
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/biblex
120 %attr(755,root,root) %{_bindir}/bibparse
121 %attr(755,root,root) %{_bindir}/dumpnames
122 %attr(755,root,root) %{_libdir}/libbtparse.so
123
124 %files -n btparse-devel
125 %defattr(644,root,root,755)
126 %{_includedir}/btparse.h
127 %{_mandir}/man3/bt_*.3*
128 %{_mandir}/man3/btparse.3*
129 %{_mandir}/man3/btool_faq.3*
This page took 0.15814 seconds and 4 git commands to generate.