]> git.pld-linux.org Git - packages/perl-Test-Without-Module.git/blob - perl-Test-Without-Module.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Without-Module.git] / perl-Test-Without-Module.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Without-Module
7 Summary:        Test::Without::Module - Test fallback behaviour in absence of modules
8 Summary(pl.UTF-8):      Test::Without::Module - testowanie rozwiązań zapasowych w przypadku braku modułów
9 Name:           perl-Test-Without-Module
10 Version:        0.20
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  34684186b66929bbcd12d3ac8ae03f9d
17 URL:            https://metacpan.org/release/Test-Without-Module
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module allows you to deliberately hide modules from a program
28 even though they are installed. This is mostly useful for testing
29 modules that have a fallback when a certain dependency module is not
30 installed.
31
32 %description -l pl.UTF-8
33 Ten moduł pozwala celowo ukrywać moduły przed programem, nawet jeśli
34 są zainstalowane. Jest to przydatne głównie do testowania modułów,
35 które mają rozwiązania zapasowe w przypadku, kiedy jakiś wymagany
36 moduł nie jest zainstalowany.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %dir %{perl_vendorlib}/Test/Without
61 %{perl_vendorlib}/Test/Without/Module.pm
62 %{_mandir}/man3/Test::Without::Module.3pm*
This page took 0.107225 seconds and 4 git commands to generate.