]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- updated to 1.302183
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Simple
7 Summary:        Test::Simple - basic utilities for writing tests
8 Summary(pl.UTF-8):      Test::Simple - podstawowe narzędzia do pisania testów
9 Name:           perl-Test-Simple
10 # NOTE: perl 5.32 provides 1.302175
11 Version:        1.302183
12 %define fver    %(echo %{version} | tr -d _)
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
18 # Source0-md5:  b9bd0b573de649893dbd1d746691cd0a
19 URL:            https://metacpan.org/release/Test-Simple
20 %{?with_tests:BuildRequires:    perl-Test-Harness >= 2.03}
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 # see lib/Test/Builder/Tester.pm /VERSION
25 Provides:       perl-Test-Builder-Tester = %{version}
26 # see lib/Test/Tester.pm /VERSION
27 Provides:       perl-Test-Tester = %{version}
28 # see lib/Test/use/ok.pm /VERSION
29 Provides:       perl-Test-use-ok = %{version}
30 # obsolete only versions up to last standalone release to avoid obsoleting perl-modules
31 # Test::Builder::Tester 1.01
32 # Test::Tester 0.109
33 # Test::use::ok 0.11
34 Obsoletes:      perl-Test-Builder-Tester < 1.02
35 Obsoletes:      perl-Test-Tester < 0.110
36 Obsoletes:      perl-Test-use-ok < 0.12
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _noautoreq_perl threads threads::shared
41
42 %description
43 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
44 me to Detroit, but don't make me write tests!
45    -- perldoc Test::Tutorial
46
47 Test::Simple is an extremely simple, extremely basic module for
48 writing tests suitable for CPAN modules and other pursuits. If you
49 wish to do more complicated testing, use the Test::More module (a
50 drop-in replacement for this one).
51
52 The purpose of Test::More is to provide a wide range of testing
53 utilities. Various ways to say "ok" with better diagnostics,
54 facilities to skip tests, test future features and compare complicated
55 data structures. While you can do almost anything with a simple "ok()"
56 function, it doesn't provide good diagnostic output.
57
58 %description -l pl.UTF-8
59 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
60 mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
61 testów!
62    -- perldoc Test::Tutorial
63
64 Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
65 pisania testów pasujących do modułów CPAN i innych. Do bardziej
66 skomplikowanych testów lepiej używać modułu Test::More (zastępującego
67 ten).
68
69 Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
70 testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
71 ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
72 porównywaniu skomplikowanych struktur danych. O ile można zrobić
73 prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
74 diagnostycznego.
75
76 %prep
77 %setup -q -n %{pdir}-%{pnam}-%{fver}
78 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
79
80 %build
81 %{__perl} Makefile.PL \
82         INSTALLDIRS=vendor
83 %{__make}
84
85 %{?with_tests:%{__make} test}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc Changes README
101 %{perl_vendorlib}/ok.pm
102 %{perl_vendorlib}/Test/Builder
103 %{perl_vendorlib}/Test/Builder.pm
104 %{perl_vendorlib}/Test/More.pm
105 %{perl_vendorlib}/Test/Simple.pm
106 %{perl_vendorlib}/Test/Tester
107 %{perl_vendorlib}/Test/Tester.pm
108 %{perl_vendorlib}/Test/use
109 %{perl_vendorlib}/Test2.pm
110 %{perl_vendorlib}/Test2
111 %{_mandir}/man3/Test::Builder*.3pm*
112 %{_mandir}/man3/Test::More.3pm*
113 %{_mandir}/man3/Test::Simple.3pm*
114 %{_mandir}/man3/Test::Tester*.3pm*
115 %{_mandir}/man3/Test::Tutorial.3pm*
116 %{_mandir}/man3/Test::use::ok.3pm*
117 %{_mandir}/man3/Test2*.3pm*
118 %{_mandir}/man3/ok.3pm*
This page took 0.06887 seconds and 4 git commands to generate.