]> git.pld-linux.org Git - packages/perl-Test-Perl-Critic.git/blob - perl-Test-Perl-Critic.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Perl-Critic.git] / perl-Test-Perl-Critic.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Test
6 %define pnam    Perl-Critic
7 Summary:        Test::Perl::Critic - Use Perl::Critic in test programs
8 Summary(pl.UTF-8):      Test::Perl::Critic - użycie Perl::Critic w programach testowych
9 Name:           perl-Test-Perl-Critic
10 Version:        1.03
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  b10da607ed6c6c07eba99e48ce77d88a
16 URL:            http://search.cpan.org/dist/Test-Perl-Critic/
17 BuildRequires:  perl-Module-Build >= 0.40
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-MCE >= 1.520
22 BuildRequires:  perl-Perl-Critic >= 1.105
23 BuildRequires:  perl-Test-Simple
24 %endif
25 Requires:       perl-MCE >= 1.520
26 Requires:       perl-Perl-Critic >= 1.105
27 Requires:       perl-dirs >= 4-4
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Test::Perl::Critic wraps the Perl::Critic engine in a convenient
33 subroutine suitable for test programs written using the Test::More
34 framework. This makes it easy to integrate coding-standards
35 enforcement into the build process. For ultimate convenience (at the
36 expense of some flexibility), see the criticism pragma.
37
38 %description -l pl.UTF-8
39 Test::Perl::Critic obudowuje silnik Perl::Critic w wygodną procedurę
40 pasującą do programów testowych pisanych z użyciem szkieletu
41 Test::More. Ułatwia to integrację wymuszania standardów kodowania w
42 proces budowania. Dla ostatecznej wygody (kosztem części
43 elastyczności) użyć pragma criticism.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes
67 %{perl_vendorlib}/Test/Perl/Critic.pm
68 %{_mandir}/man3/Test::Perl::Critic.3*
This page took 0.076768 seconds and 4 git commands to generate.