]> git.pld-linux.org Git - packages/perl-Test-Needs.git/blob - perl-Test-Needs.spec
- updated to 0.002010
[packages/perl-Test-Needs.git] / perl-Test-Needs.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Needs
7 Summary:        Test::Needs - skip tests when modules not available
8 Summary(pl.UTF-8):      Test::Needs - pomijanie testów, jeśli moduły nie są dostępne
9 Name:           perl-Test-Needs
10 Version:        0.002010
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2b3d10946001561297624e7668f09c26
17 URL:            https://metacpan.org/release/Test-Needs
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple >= 0.45
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Skip test scripts if modules are not available. The requested modules
29 will be loaded, and optionally have their versions checked. If the
30 module is missing, the test script will be skipped. Modules that are
31 found but fail to compile will exit with an error rather than skip.
32
33 %description -l pl.UTF-8
34 Moduł pozwalający na pomijanie skryptów testowych, jeśli moduły nie są
35 dostępne. Żądane moduły są ładowane, a ich wersje opcjonalnie
36 sprawdzane. Jeśli modułu brakuje, skrypt testowy jest pomijany; moduły
37 znalezione, ale nie kompilujące się powodują zakończenie testu z
38 błędem zamiast pominięcia.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Test/Needs.pm
63 %{_mandir}/man3/Test::Needs.3*
This page took 0.138335 seconds and 4 git commands to generate.