]> git.pld-linux.org Git - packages/perl-Test-Most.git/blob - perl-Test-Most.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Most.git] / perl-Test-Most.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Most
7 Summary:        Test::Most - Most commonly needed test functions and features
8 Summary(pl.UTF-8):      Test::Most - najczęściej potrzebne funkcje testowe
9 Name:           perl-Test-Most
10 Version:        0.35
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  03dbabd34d6f40af8bd47f5fbb0c6989
17 URL:            http://search.cpan.org/dist/Test-Most/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Exception-Class >= 1.14
22 BuildRequires:  perl-Test-Deep >= 0.119
23 BuildRequires:  perl-Test-Differences >= 0.64
24 BuildRequires:  perl-Test-Exception >= 0.43
25 BuildRequires:  perl-Test-Harness >= 3.35
26 BuildRequires:  perl-Test-Simple >= 1.302047
27 BuildRequires:  perl-Test-Warn >= 0.30
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Test::Most exists to reduce boilerplate and to make your testing life
34 easier. We provide "one stop shopping" for most commonly used testing
35 modules. In fact, we often require the latest versions so that you get
36 bug fixes through Test::Most and don't have to keep upgrading these
37 modules separately.
38
39 This module provides you with the most commonly used testing
40 functions, along with automatically turning on strict and warning and
41 gives you a bit more fine-grained control over your test suite.
42
43 %description -l pl.UTF-8
44 Celem Test::Most jest zmniejszenie ilości ramowego kodu i ułatwienie
45 testowania. Moduł pozwala na jednoczesne włączenie najczęściej
46 używanych modułów testowych; zwykle wymagane są najnowsze wersje, aby
47 zapewnić poprawienie znanych błędów bez potrzeby uaktualniania modułów
48 osobno.
49
50 Test::Most dostarcza najczęściej używane funkcje testujące,
51 jednocześnie włączając tryb ścisły (strict) i ostrzeżenia, a także
52 pozwalając na elastyczną kontrolę zestawu testów.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorlib}/Test/Most.pm
77 %{perl_vendorlib}/Test/Most
78 %{_mandir}/man3/Test::Most.3pm*
79 %{_mandir}/man3/Test::Most::Exception.3pm*
This page took 0.075942 seconds and 4 git commands to generate.