]> git.pld-linux.org Git - packages/perl-Test-Fatal.git/blob - perl-Test-Fatal.spec
- updated to 0.016
[packages/perl-Test-Fatal.git] / perl-Test-Fatal.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Fatal
7 Summary:        Test::Fatal - incredibly simple helpers for testing code with exceptions
8 Summary(pl.UTF-8):      Test::Fatal - bardzo proste funkcje pomocnicze do kodu testującego z wyjątkami
9 Name:           perl-Test-Fatal
10 Version:        0.016
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  da5d864c04a60e71de9ae51b318562fd
17 URL:            https://metacpan.org/release/Test-Fatal
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.7
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl(Exporter) >= 5.57
24 BuildRequires:  perl-Test-Simple >= 0.96
25 BuildRequires:  perl-Try-Tiny >= 0.07
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Test::Fatal is an alternative to the popular Test::Exception. It does
32 much less, but should allow greater flexibility in testing
33 exception-throwing code with about the same amount of typing.
34
35 %description -l pl.UTF-8
36 Test::Fatal to alternatywa dla popularnego Test::Exception. Ten moduł
37 robi znacznie mniej, ale powinien pozwalać na większą elastyczność
38 przy testowaniu kodu rzucającego wyjątki przy mniej więcej tej samej
39 ilości napisanego kodu.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/Test/Fatal.pm
64 %{_mandir}/man3/Test::Fatal.3pm*
This page took 0.084994 seconds and 4 git commands to generate.