]> git.pld-linux.org Git - packages/perl-Test-Exception.git/blob - perl-Test-Exception.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Exception.git] / perl-Test-Exception.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Exception
7 Summary:        Test::Exception - convenience routines for testing exception based code
8 Summary(pl.UTF-8):      Test::Exception - wygodne funkcje do testowania kodu bazującego na wyjątkach
9 Name:           perl-Test-Exception
10 Version:        0.43
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  572d355026fb0b87fc2b8c64b83cada0
17 URL:            http://search.cpan.org/dist/Test-Exception/
18 %if %{with tests}
19 BuildRequires:  perl(Test::Builder) >= 0.70
20 BuildRequires:  perl-Sub-Uplevel >= 0.18
21 BuildRequires:  perl-Test-Builder-Tester >= 1.07
22 BuildRequires:  perl-Test-Harness >= 2.03
23 BuildRequires:  perl-Test-Simple >= 0.70
24 %endif
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 Requires:       perl(Test::Builder) >= 0.70
28 Requires:       perl-Sub-Uplevel >= 0.18
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module provides a few convenience methods for testing exception
34 based code.  It is built with Test::Builder and plays happily with
35 Test::More and friends.
36
37 %description -l pl.UTF-8
38 Ten moduł udostępnia kilka wygodnych metod do testowania kodu
39 bazującego na wyjątkach. Jest budowany z użyciem Test::Builder, działa
40 sprawnie z Test::More i przyległościami.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{perl_vendorlib}/Test/Exception.pm
64 %{_mandir}/man3/Test::Exception.3pm*
This page took 0.055089 seconds and 4 git commands to generate.