]> git.pld-linux.org Git - packages/perl-Test-Distribution.git/blob - perl-Test-Distribution.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Distribution.git] / perl-Test-Distribution.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_with     tests           # perform "make test" (requires network access)
5 #
6 %define         pdir    Test
7 %define         pnam    Distribution
8 Summary:        Test::Distribution - perform tests on all modules of a distribution
9 Summary(pl.UTF-8):      Test::Distribution - wykonywanie testów na wszystkich modułach z dystrybucji
10 Name:           perl-Test-Distribution
11 Version:        2.00
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7b7f905605f60a786f2ece2d76230fd1
18 URL:            http://search.cpan.org/dist/Test-Distribution/
19 %{?with_tests:BuildRequires:    gnupg-plugin-keys_hkp}
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with autodeps} || %{with tests}
24 BuildRequires:  perl-File-Find-Rule
25 BuildRequires:  perl-Module-CoreList >= 1.93
26 BuildRequires:  perl-Module-Signature
27 BuildRequires:  perl-Pod-Coverage >= 0.17
28 BuildRequires:  perl-Test-Pod-Coverage
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 When using this module in a test script, it goes through all the
35 modules in your distribution, checks their POD, checks that they
36 compile ok and checks that they all define a $VERSION.
37
38 This module also performs a numer of test on the distribution itself.
39 It checks that your files match your SIGNATURE file if you have one.
40 It checks that your distribution isn't missing certain 'core'
41 description files. It checks to see you haven't missed out listing any
42 pre-requisites in Makefile.PL.
43
44 %description -l pl.UTF-8
45 W przypadku użycia tego modułu w skrypcie testowym, przechodzi on po
46 wszystkich modułach w dystrybucji, sprawdzając ich POD, czy się
47 poprawnie kompilują oraz czy wszystkie definiują $VERSION.
48
49 Ten moduł wykonuje także testy na samej dystrybucji. Sprawdza, czy
50 pliki zgadzają się z plikiem SIGNATURE, jeśli takowy istnieje.
51 Sprawdza, czy w dystrybucji nie brakuje jakichś głównych plików z
52 opisem. Sprawdza, czy nie zapomniano wymienić wszystkich zależności w
53 Makefile.PL.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Build.PL \
60         --installdirs=vendor 
61
62 ./Build
63
64 %{?with_tests:./Build test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 ./Build install \
70         --destdir=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README
78 %{perl_vendorlib}/Test/Distribution.pm
79 %{_mandir}/man3/*
This page took 0.0720229999999999 seconds and 4 git commands to generate.