]> git.pld-linux.org Git - packages/perl-Test-CleanNamespaces.git/blob - perl-Test-CleanNamespaces.spec
- updated to 0.24
[packages/perl-Test-CleanNamespaces.git] / perl-Test-CleanNamespaces.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Test
6 %define         pnam    CleanNamespaces
7 Summary:        Test::CleanNamespaces - Check for uncleaned imports
8 Summary(pl.UTF-8):      Test::CleanNamespace - sprawdzanie zanieczyszczonych importów
9 Name:           perl-Test-CleanNamespaces
10 Version:        0.24
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0ddfb7e5f11ddfb9498cb500c7616fb8
17 URL:            https://metacpan.org/release/Test-CleanNamespaces
18 BuildRequires:  perl-CPAN-Meta-Requirements >= 2.120_620
19 BuildRequires:  perl-ExtUtils-MakeMaker
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-Module-Runtime
25 BuildRequires:  perl-Package-Stash >= 0.14
26 BuildRequires:  perl-Sub-Exporter
27 BuildRequires:  perl-Sub-Identify
28 BuildRequires:  perl-Test-Deep
29 BuildRequires:  perl-Test-Requires
30 BuildRequires:  perl-Test-Simple >= 0.96
31 BuildRequires:  perl-Test-Tester
32 BuildRequires:  perl-Test-Warnings >= 0.009
33 BuildRequires:  perl-namespace-clean
34 %endif
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This module lets you check your module's namespaces for imported
40 functions you might have forgotten to remove with namespace::autoclean
41 or namespace::clean and are therefore available to be called as
42 methods, which usually isn't want you want.
43
44 %description -l pl.UTF-8
45 Ten moduł pozwala sprawdzić przestrzenie nazw modułu, czy nie
46 zapomniano z nich usunąć zaimportowanych funkcji przy użyciu
47 namespace::autoclean lub namespace::clean, przez co mogłyby być
48 dostępne jako metody, co jest zwykle niepożądane.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes INSTALL README
72 %{perl_vendorlib}/Test/CleanNamespaces.pm
73 %{_mandir}/man3/Test::CleanNamespaces.3pm*
This page took 0.091836 seconds and 4 git commands to generate.