]> git.pld-linux.org Git - packages/perl-Test-ClassAPI.git/blob - perl-Test-ClassAPI.spec
- updated to 0.07
[packages/perl-Test-ClassAPI.git] / perl-Test-ClassAPI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    ClassAPI
7 Summary:        Test::ClassAPI - provides basic first-pass API testing for large class trees
8 Summary(pl.UTF-8):      Test::ClassAPI - podstawowy pierwszy przebieg testowania API dużych drzew klas
9 Name:           perl-Test-ClassAPI
10 Version:        1.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ff06bc671f753f4148c39df08fb6dd98
17 URL:            https://metacpan.org/release/Test-ClassAPI
18 %if %{with tests}
19 BuildRequires:  perl(File::Spec) >= 0.83
20 BuildRequires:  perl-Class-Inspector >= 1.12
21 BuildRequires:  perl-Config-Tiny >= 2.00
22 BuildRequires:  perl-Params-Util >= 1.00
23 BuildRequires:  perl-Test-Simple >= 0.47
24 %endif
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRequires:  rpmbuild(macros) >= 1.745
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 For many APIs with large numbers of classes, it can be very useful to
33 be able to do a quick once-over to make sure that classes, methods,
34 and inheritance is correct, before doing more comprehensive testing.
35 This module aims to provide such a capability.
36
37 %description -l pl.UTF-8
38 Przy wielu API z dużą liczbą klas może być bardzo przydatna możliwość
39 wykonania szybkiego przebiegu, aby upewnić się przed rozpoczęciem
40 bardziej rozległego testowania, że te klasy, metody i dziedziczenie są
41 poprawne. Ten moduł próbuje dostarczyć taką możliwość.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/Test/ClassAPI.pm
66 %{_mandir}/man3/Test::ClassAPI.3pm*
This page took 0.055587 seconds and 4 git commands to generate.