]> git.pld-linux.org Git - packages/perl-Test-Block.git/blob - perl-Test-Block.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Block.git] / perl-Test-Block.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Test
6 %define pnam    Block
7 Summary:        Test::Block - Specify fine granularity test plans
8 Summary(pl.UTF-8):      Test::Block - określanie szczegółowych planów testów
9 Name:           perl-Test-Block
10 Version:        0.13
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f4e289f7f2a333983f1e4d578d82f5a3
17 # https://rt.cpan.org/Ticket/Attachment/1600903/856113/0001-Make-Test-Block-work-with-perl-5.23.8.patch
18 Patch0:         %{name}-perl5.24.patch
19 URL:            http://search.cpan.org/dist/Test-Block/
20 BuildRequires:  perl-Module-Build >= 0.38
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.672
24 %if %{with tests}
25 BuildRequires:  perl(Test::Builder) >= 0.17
26 BuildRequires:  perl-Test-Builder-Tester >= 1.01
27 BuildRequires:  perl-Test-Exception >= 0.15
28 BuildRequires:  perl-Test-Simple >= 0.47
29 %endif
30 Requires:       perl-base
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # provided by Tie::Scalar (perl-base)
35 %define         _noautoreq_perl Tie::StdScalar
36
37 %description
38 This module allows you to specify the number of expected tests at a
39 finer level of granularity than an entire test script. It is built
40 with Test::Builder and plays happily with Test::More and friends.
41
42 %description -l pl.UTF-8
43 Ten moduł pozwala na określanie liczby oczekiwanych testów na poziomie
44 dokładniejszym niż cały skrypt testowy. Jest stworzony w oparciu o
45 Test::Builder i dobrze współpracuje z Test::More oraz podobnymi.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49 %patch0 -p2
50
51 %build
52 %{__perl} Build.PL \
53         destdir=$RPM_BUILD_ROOT \
54         installdirs=vendor
55 ./Build
56
57 %{?with_tests:./Build test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 ./Build install
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Test/Block.pm
71 %{_mandir}/man3/Test::Block.3pm*
This page took 0.071453 seconds and 4 git commands to generate.