]> git.pld-linux.org Git - packages/perl-Test-Assertions.git/blob - perl-Test-Assertions.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Assertions.git] / perl-Test-Assertions.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Test
6 %define pnam    Assertions
7 Summary:        Test::Assertions - a simple set of building blocks for both unit and runtime testing
8 Summary(pl.UTF-8):      Test::Assertions - prosty zestaw klocków do testów jednostkowych i czasu uruchomienia
9 Name:           perl-Test-Assertions
10 Version:        1.054
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/B/BB/BBC/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  71359868674fd4290bd7d9da407c1cda
17 URL:            http://search.cpan.org/dist/Test-Assertions/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Log::Trace)
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Test::Assertions provides a convenient set of tools for constructing
28 tests, such as unit tests or run-time assertion checks (like C's
29 ASSERT macro). Unlike some of the Test:: modules available on CPAN,
30 Test::Assertions is not limited to unit test scripts; for example it
31 can be used to check output is as expected within a benchmarking
32 script. When it is used for unit tests, it generates output in the
33 standard form for CPAN unit testing (under Test::Harness).
34
35 # %description -l pl.UTF-8
36 # TODO
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Test/*.pm
61 %{perl_vendorlib}/Test/Assertions
62 %{_mandir}/man3/*
This page took 0.114173 seconds and 4 git commands to generate.