]> git.pld-linux.org Git - packages/perl-Term-Size-Any.git/blob - perl-Term-Size-Any.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Term-Size-Any.git] / perl-Term-Size-Any.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Term
6 %define pnam    Size-Any
7 Summary:        Term::Size::Any - Retrieve terminal size
8 #Summary(pl.UTF-8):
9 Name:           perl-Term-Size-Any
10 Version:        0.001
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Term/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  58722dad73c6965d5c4b975e3ae47116
17 URL:            http://search.cpan.org/dist/Term-Size-Any/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Devel::Hide)
22 BuildRequires:  perl(Term::Size::Perl)
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a unified interface to retrieve terminal size. It loads one
29 module of a list of known alternatives, each implementing some way to
30 get the desired terminal information. This loaded module will actually
31 do the job on behalf of Term::Size::Any.
32
33 Thus, Term::Size::Any depends on the availability of one of these
34 modules:
35
36 Term::Size (soon to be supported) Term::Size::Perl Term::Size::ReadKey
37 (soon to be supported) Term::Size::Win32
38
39 This release fallbacks to Term::Size::Win32 if running in Windows 32
40 systems. For other platforms, it uses the first of Term::Size::Perl,
41 Term::Size or Term::Size::ReadKey which loads successfully. (To be
42 honest, I disabled the fallback to Term::Size and Term::Size::ReadKey
43 which are buggy by now.)
44
45 # %description -l pl.UTF-8
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/Term/Size/*.pm
70 %{_mandir}/man3/*
This page took 0.09904 seconds and 4 git commands to generate.