]> git.pld-linux.org Git - packages/perl-Term-ReadKey.git/blob - perl-Term-ReadKey.spec
perl 5.38.0 rebuild
[packages/perl-Term-ReadKey.git] / perl-Term-ReadKey.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # requires terminal
5 #
6 %define         pdir    Term
7 %define         pnam    ReadKey
8 Summary:        Term::ReadKey - Perl module for simple terminal control
9 Summary(pl.UTF-8):      Term::ReadKey - moduł Perla do prostego sterowania terminalem
10 Name:           perl-Term-ReadKey
11 Version:        2.38
12 Release:        6
13 License:        BSD-like
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Term/%{pdir}%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b2b4aab7a0e6bddb7ac3b21ba637482c
17 URL:            https://metacpan.org/dist/TermReadKey
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 3.5
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 Obsoletes:      perl-TermReadKey < 2.38
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module, Term::ReadKey, provides ioctl control for terminals so
27 the input modes can be changed (thus allowing reads of a single
28 character at a time), and also provides non-blocking reads of stdin,
29 as well as several other terminal related features, including
30 retrieval/modification of the screen size, and retrieval/modification
31 of the control characters.
32
33 %description -l pl.UTF-8
34 Moduł Perla Term::ReadKey udostępnia obsługę ioctl dla terminali,
35 umożliwiając zmianę trybu wejścia (co pozwala na czytanie po jednym
36 znaku) oraz nieblokujący odczyt z wejścia, a także inne funkcje
37 związane z terminalem, w tym odczytywanie i modyfikowanie rozmiaru
38 ekranu oraz odczytywanie i modyfikowanie znaków kontrolnych.
39
40 %description -l pt_BR.UTF-8
41 Este módulo fornece controle via ioctl para terminais, de tal forma
42 que seus modos de entrada possam ser modificados (desta forma
43 permitindo a leitura de um caracter somente por vez) e também fornece
44 leitura não bloqueantes da entrada padrão (stdin), bem como várias
45 outras características relacionadas a terminais, entre elas a
46 recuperação/modificação do tamanho da tela e dos caracteres de
47 controle.
48
49 %prep
50 %setup -q -n TermReadKey-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make} \
56         CC="%{__cc}" \
57         OPTIMIZE="%{rpmcflags}"
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README
73 %{perl_vendorarch}/Term/ReadKey.pm
74 %dir %{perl_vendorarch}/auto/Term/ReadKey
75 # empty autosplit.ix
76 #%%{perl_vendorarch}/auto/Term/ReadKey/autosplit.ix
77 %attr(755,root,root) %{perl_vendorarch}/auto/Term/ReadKey/ReadKey.so
78 %{_mandir}/man3/Term::ReadKey.3pm*
This page took 0.119341 seconds and 4 git commands to generate.