]> git.pld-linux.org Git - packages/perl-Template-DBI.git/blob - perl-Template-DBI.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Template-DBI.git] / perl-Template-DBI.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define         pdir    Template
7 %define         pnam    DBI
8 Summary:        DBI plugin for Template Toolkit - database access
9 Summary(pl.UTF-8):      Wtyczka DBI dla pakietu Template Toolkit - dostęp do baz danych
10 Name:           perl-Template-DBI
11 Version:        2.64
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Template/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  424d2f17b8b2b3329e758044210920cb
18 URL:            http://search.cpan.org/dist/Template-DBI/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl(File::Spec) >= 0.6
21 BuildRequires:  perl-AppConfig >= 1.52
22 %if %{with autodeps} || %{with tests}
23 BuildRequires:  perl-DBI >= 1.14
24 BuildRequires:  perl-Pod-POM >= 0.1
25 BuildRequires:  perl-Template-Toolkit >= 2.15
26 BuildRequires:  perl-Text-Autoformat >= 1.03
27 %endif
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 Requires:       perl-Template-Toolkit >= 2.15
30 Obsoletes:      perl-Template-Toolkit-Plugin-DBI
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 DBI plugin for Template Toolkit - interface to the DBI module. It
36 provides an interface to the Perl DBI/DBD modules, allowing you to
37 integrate SQL queries into your template documents. It also provides
38 an interface via the Tie::DBI module (if installed on your system) so
39 that you can access database records without having to embed any SQL
40 in your templates.
41
42 %description -l pl.UTF-8
43 Wtyczka DBI dla pakietu Template Toolkit - będąca interfejsem do
44 modułu DBI. Daje dostęp do modułów Perla DBI/DBD, pozwalając na
45 integrowanie zapytań SQL do dokumentów szablonów. Udostępnia także
46 interfejs poprzez moduł Tie::DBI (jeśli jest zainstalowany), co
47 pozwala na dostęp do rekordów bazy danych bez potrzeby osadzania SQL-a
48 w szablonach.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 echo "n" | %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %{perl_vendorlib}/Template/Plugin/DBI.pm
72 %{_mandir}/man3/*
This page took 0.063583 seconds and 4 git commands to generate.