]> git.pld-linux.org Git - packages/perl-Sys-Mmap.git/blob - perl-Sys-Mmap.spec
perl 5.38.0 rebuild
[packages/perl-Sys-Mmap.git] / perl-Sys-Mmap.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Sys
6 %define         pnam    Mmap
7 Summary:        Sys::Mmap - Perl module that allows to use mmap to map in a file as a Perl variable
8 Name:           perl-Sys-Mmap
9 Version:        0.19
10 Release:        6
11 # sae as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  990c9106a88dc843035f7bcb109e6c0e
16 URL:            http://search.cpan.org/dist/Sys-Mmap/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Mmap - uses mmap to map in a file as a Perl variable.
23
24 %prep
25 %setup -q -n %{pdir}-%{pnam}-%{version}
26
27 %build
28 %{__perl} Makefile.PL \
29         INSTALLDIRS=vendor
30 %{__make} \
31         CC="%{__cc}" \
32         OPTIMIZE="%{rpmcflags}"
33
34 %{?with_tests:%{__make} test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 %{__make} install \
40         DESTDIR=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc Change* README
48 %{perl_vendorarch}/Sys/*.pm
49 %dir %{perl_vendorarch}/auto/Sys/Mmap
50 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Mmap/*.so
51 %{_mandir}/man3/*
This page took 0.128278 seconds and 4 git commands to generate.