]> git.pld-linux.org Git - packages/perl-Switch.git/blob - perl-Switch.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Switch.git] / perl-Switch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Switch
6 Summary:        Switch - a switch statement for Perl
7 Summary(pl.UTF-8):      Switch - instrukcja switch dla Perla
8 Name:           perl-Switch
9 Version:        2.17
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/C/CH/CHORNY/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  34e2b6dac0a43384505b4e036633cff0
16 URL:            http://search.cpan.org/dist/Switch/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Switch.pm provides the syntax and semantics for an explicit case
24 mechanism for Perl.  The syntax is minimal, introducing only the
25 keywords "switch" and "case" and conforming to the general pattern of
26 existing Perl control structures.  The semantics are particularly
27 rich, allowing any one (or more) of nearly 30 forms of matching to be
28 used when comparing a switch value with its various cases.
29
30 %description -l pl.UTF-8
31 Switch.pm udostępnia składnię i semantykę dla jawnego mechanizmu
32 rozpatrywania przypadku dla Perla.  Składnia jest minimalna, wprowadza
33 jedynie słowa kluczowe ,,switch'' i ,,case'' i zachowując zgodność
34 z ogólnym wzorcem istniejących procedur kontroli przepływu Perla.
35
36 %prep
37 %setup -q -n %{pdir}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Switch.pm
59 %{_mandir}/man3/Switch.3pm*
This page took 0.087125 seconds and 4 git commands to generate.