]> git.pld-linux.org Git - packages/perl-Sort-Key.git/blob - perl-Sort-Key.spec
perl 5.38.0 rebuild
[packages/perl-Sort-Key.git] / perl-Sort-Key.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Sort
6 %define         pnam    Key
7 Summary:        Sort::Key - interface to sort arrays by one or manipulate calculated keys
8 Summary(pl.UTF-8):      Sort::Key - interfejs do szybkiego sortowania tablic wedÅ‚ug zmiennych kluczy
9 Name:           perl-Sort-Key
10 Version:        1.33
11 Release:        3
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Sort/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a37ab0da0cfdc26e57b4c79e39f6d98f
17 URL:            https://metacpan.org/dist/Sort-Key
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Sort arrays by one or multiple calculated keys.
25
26 %description -l pl.UTF-8
27 Sortowanie tablic po jednym lub wielu wyliczanych kluczach.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make} \
36         CC="%{__cc}" \
37         OPTIMIZE="%{rpmcflags}"
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes README
53 %{perl_vendorarch}/Sort/Key.pm
54 %dir %{perl_vendorarch}/Sort
55 %{perl_vendorarch}/Sort/Key
56 %dir %{perl_vendorarch}/auto/Sort
57 %dir %{perl_vendorarch}/auto/Sort/Key
58 %attr(755,root,root) %{perl_vendorarch}/auto/Sort/Key/Key.so
59 %{_mandir}/man3/Sort::Key*.3pm*
This page took 0.107921 seconds and 4 git commands to generate.