]> git.pld-linux.org Git - packages/perl-Shell-Config-Generate.git/blob - perl-Shell-Config-Generate.spec
- new
[packages/perl-Shell-Config-Generate.git] / perl-Shell-Config-Generate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Shell
6 %define         pnam    Config-Generate
7 Summary:        Shell::Config::Generate - portably generate config for any shell
8 Summary(pl.UTF-8):      Shell::Config::Generate - przenośne generowanie konfiguracji dla dowolnej powłoki
9 Name:           perl-Shell-Config-Generate
10 Version:        0.34
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Shell/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1068869e6ae124abdd7a20b5c901ccb8
17 URL:            https://metacpan.org/release/Shell-Config-Generate
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl(Test2::API) >= 1.302015
23 BuildRequires:  perl-Shell-Guess >= 0.02
24 BuildRequires:  perl-Test2-Suite >= 0.000060
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module provides an interface for specifying shell configurations
31 for different shell environments without having to worry about the
32 arcane differences between shells such as csh, sh, cmd.exe and
33 command.com.
34
35 It does not modify the current environment, but it can be used to
36 create shell configurations which do modify the environment.
37
38 %description -l pl.UTF-8
39 Ten moduł udostępnia interfejs do opisywania konfiguracji powłoki dla
40 środowisk różnych powłok bez przejmowania się różnicami między
41 powłokami, takimi jak csh, sh, cmd.exe czy command.com.
42
43 Moduł nie modyfikuje bieżącego środowiska, ale może być użyty do
44 tworzenia konfiguracji powłok modyfikujących środowiko.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 cp -p example/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %dir %{perl_vendorlib}/Shell/Config
72 %{perl_vendorlib}/Shell/Config/Generate.pm
73 %{_mandir}/man3/Shell::Config::Generate.3pm*
74 %{_examplesdir}/%{name}-%{version}
This page took 0.09313 seconds and 4 git commands to generate.