]> git.pld-linux.org Git - packages/perl-Set-Array.git/blob - perl-Set-Array.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Set-Array.git] / perl-Set-Array.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Set
6 %define         pnam    Array
7 Summary:        Set::Array - arrays as objects with lots of handy methods
8 Summary(pl.UTF-8):      Set::Array - tablice jako obiekty z wieloma poręcznymi metodami
9 Name:           perl-Set-Array
10 Version:        0.23
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Set/%{pdir}-%{pnam}-%{version}.tgz
15 # Source0-md5:  7291a3b10383791dc5bc52a0d1e9113a
16 URL:            http://search.cpan.org/dist/Set-Array/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 %if %{with tests}
19 BuildRequires:  perl-Want >= 0.05
20 BuildRequires:  perl-Test-Deep
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Set::Array allows you to create arrays as objects and use OO-style
28 methods on them. Many convenient methods are provided here that appear
29 in the FAQ's, the Perl Cookbook or posts from comp.lang.perl.misc. In
30 addition, there are Set methods with corresponding (overloaded)
31 operators for the purpose of Set comparison, i.e. +, ==, etc.
32
33 %description -l pl.UTF-8
34 Set::Array pozwala na tworzenie tablic jako obiektów i używanie na
35 nich metod. Dostępnych jest wiele wygodnych metod, które podane są w
36 FAQ-ach, Perl Cookbook oraz postach z grupy comp.lang.perl.misc.
37 Dodatkowo są metody Set z odpowiadającymi (przeciążonymi) operatorami
38 do porównywania, np. +, == itd.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %{perl_vendorlib}/%{pdir}/*.pm
61 %{_mandir}/man3/*
This page took 0.075537 seconds and 4 git commands to generate.