]> git.pld-linux.org Git - packages/perl-SVN-Dump.git/blob - perl-SVN-Dump.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-SVN-Dump.git] / perl-SVN-Dump.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    SVN
6 %define         pnam    Dump
7 Summary:        SVN::Dump - A Perl interface to Subversion dumps
8 Name:           perl-SVN-Dump
9 Version:        0.05
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/SVN/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  c7e62a0399e608bdd9b0968829310490
16 URL:            http://search.cpan.org/dist/SVN-Dump/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 An SVN::Dump object represents a Subversion dump.
25
26 This module follow the semantics used in the reference document (the
27 file notes/fs_dumprestore.txt in the Subversion source tree):
28
29 The most basic thing you can do with SVN::Dump is simply copy a dump.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Build.PL \
36         destdir=$RPM_BUILD_ROOT \
37         installdirs=vendor
38 ./Build
39
40 %{?with_tests:./Build test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 ./Build install
45
46 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/SVN/Dump.pm
56 %{perl_vendorlib}/SVN/Dump
57 %{_mandir}/man3/SVN::Dump*
58 %{_examplesdir}/%{name}-%{version}
This page took 0.110155 seconds and 4 git commands to generate.