]> git.pld-linux.org Git - packages/perl-SVG-Parser.git/blob - perl-SVG-Parser.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-SVG-Parser.git] / perl-SVG-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    SVG
6 %define         pnam    Parser
7 Summary:        SVG::Parser - converts SVG XML documents into SVG objects
8 Summary(pl.UTF-8):      SVG::Parser - konwersja dokumentów SVG XML do obiektów SVG
9 Name:           perl-SVG-Parser
10 Version:        1.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  58e1f95faede185edf0657abc443f668
17 URL:            http://search.cpan.org/dist/SVG-Parser/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-SVG >= 2.0
22 BuildRequires:  perl-XML-Parser
23 BuildRequires:  perl-XML-SAX
24 %endif
25 Requires:       perl-SVG >= 2.0
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 SVG::Parser is an XML parser that converts SVG XML documents into SVG
31 objects that may then be manipulated by the SVG module before being
32 regenerated into XML. It will work using any installed Expat or SAX
33 parser, and may be given preferred list of parsers to try; the first
34 to load successfully will be used.
35
36 %description -l pl.UTF-8
37 SVG::Parser to analizator XML-a konwertujący dokumenty SVG XML na
38 obiekty SVG, którymi można manipulować przy użyciu modułu SVG przed
39 ponownym przekształceniem na XML. Moduł działa z dowolnym
40 zainstalowanym analizatorem Expat lub SAX, można podać listę
41 preferowanych analizatorów - zostanie użyty pierwszy, który uda się
42 załadować.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Build.PL \
49         destdir=$RPM_BUILD_ROOT \
50         installdirs=vendor
51 ./Build
52
53 %{?with_tests:./Build test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 ./Build install
59
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README
69 %{perl_vendorlib}/SVG/Parser.pm
70 %{perl_vendorlib}/SVG/Parser
71 %{_mandir}/man3/*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.167068 seconds and 4 git commands to generate.