]> git.pld-linux.org Git - packages/perl-Regexp-Assemble.git/blob - perl-Regexp-Assemble.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Regexp-Assemble.git] / perl-Regexp-Assemble.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Regexp
6 %define pnam    Assemble
7 Summary:        Regexp::Assemble - Assemble multiple Regular Expressions into a single RE
8 #Summary(pl.UTF-8):     
9 Name:           perl-Regexp-Assemble
10 Version:        0.35
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Regexp/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  315796ece5bfb69b166846ced911cf0e
17 URL:            http://search.cpan.org/dist/Regexp-Assemble/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Regexp::Assemble takes an arbitrary number of regular expressions
25 and assembles them into a single regular expression (or RE) that
26 matches all that the individual REs match.
27
28 # %description -l pl.UTF-8
29 # TODO
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes TODO
56 %{perl_vendorlib}/Regexp/*.pm
57 %{_mandir}/man3/*
58 %{_examplesdir}/%{name}-%{version}
This page took 0.069717 seconds and 4 git commands to generate.