]> git.pld-linux.org Git - packages/perl-Readonly.git/blob - perl-Readonly.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Readonly.git] / perl-Readonly.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Readonly
6 Summary:        Readonly - facility for creating read-only scalars, arrays, hashes
7 Summary(pl.UTF-8):      Readonly - udogodnienie do tworzenia zmiennych tylko do odczytu
8 Name:           perl-Readonly
9 Version:        2.05
10 Release:        1
11 # same as perl 5
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/S/SA/SANKO/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  acae851d7d55c509f5f00a8849597e54
16 URL:            http://search.cpan.org/dist/Readonly/
17 BuildRequires:  perl-Module-Build-Tiny >= 0.035
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple
22 BuildRequires:  perl-Test-Harness
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a facility for creating non-modifiable variables. This is
29 useful for configuration files, headers, etc. It can also be useful as
30 a development and debugging tool, for catching updates to variables
31 that should not be changed.
32
33 %description -l pl.UTF-8
34 Readonly umożliwia tworzenie niemodyfikowalnych zmiennych.  Jest to
35 użyteczne w plikach konfiguracyjnych, nagłówkach, itp.  Może być także
36 przydatne jako narzędzie do rozwijania programów i wyszukiwania
37 błędów, wyłapując próby zapisu do zmiennych, które nie powinny być
38 zmieniane.
39
40 %prep
41 %setup -q -n %{pdir}-%{version}
42
43 %build
44 %{__perl} Build.PL
45
46 ./Build
47
48 %{?with_tests:./Build test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 ./Build install \
54         --destdir=$RPM_BUILD_ROOT \
55         --installdirs=vendor
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README.md
63 %{perl_vendorlib}/Readonly.pm
64 %{_mandir}/man3/Readonly.3pm*
This page took 0.062495 seconds and 3 git commands to generate.