]> git.pld-linux.org Git - packages/perl-RPC-XML.git/blob - perl-RPC-XML.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-RPC-XML.git] / perl-RPC-XML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    RPC
6 %define         pnam    XML
7 Summary:        RPC::XML - an implementation of XML-RPC for Perl
8 Summary(pl.UTF-8):      RPC::XML - implementacja standardu XML-RPC dla Perla
9 Name:           perl-RPC-XML
10 Version:        0.76
11 Release:        2
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  731aaf588e6bd45b3a9cece8d4223e48
16 Patch0:         mod_perl2.patch
17 URL:            http://www.blackperl.com/RPC::XML/
18 BuildRequires:  perl-XML-Parser
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl-libwww
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 BuildArch:      noarch
24
25 # these are provided by mod_perl's Apache2::compat
26 %define         _noautoreq      perl(Apache) perl(Apache::Constants) perl(Apache::File)
27
28 %description
29 The RPC::XML package for Perl is an implementation of the XML-RPC
30 standard as defined at <http://www.xmlrpc.com/spec/>. It is written in
31 pure Perl without use or need of C (or XS) linkage. It does (at
32 present) require the XML::Parser and LWP CPAN modules for operation.
33 Version 0.60 will switch to XML::LibXML in place of XML::Parser.
34
35 %description -l pl.UTF-8
36 Pakiet RPC::XML jest implementacją standardu XML-RPC zdefiniowanego na
37 <http://www.xmlrpc.com/spec/>. Jest napisany wyłącznie w Perlu, bez
38 łączenia z C (ani XS). Aktualnie wymaga do działania modułów
39 XML::Parser i LWP z CPAN. Wersja 0.60 bedzie u?ywa? XML::LibXML zamiast
40 XML::Parser.
41
42 %package Apache
43 Summary:        RPC server as an Apache/mod_perl content handler
44 Summary(pl.UTF-8):      Serwer RPC jako procedura obsługi treści Apache/mod_perl
45 Group:          Applications/Networking
46
47 %description Apache
48 RPC server as an Apache/mod_perl content handler.
49
50 %description Apache -l pl.UTF-8
51 Serwer RPC jako procedura obsługi treści Apache/mod_perl.
52
53 %prep
54 %setup -q -n %{pdir}-%{pnam}-%{version}
55 %patch0 -p1
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_bindir}/*
76 %doc ChangeLog README
77 %dir %{perl_vendorlib}/RPC
78 %{perl_vendorlib}/RPC/XML
79 %{perl_vendorlib}/RPC/XML.pm
80 %{_mandir}/man3/*
81 %exclude %{_mandir}/man3/Apache*
82 %{_mandir}/man1/*
83
84 %files Apache
85 %defattr(644,root,root,755)
86 %doc README.apache2
87 %{perl_vendorlib}/Apache/RPC
88 %{_mandir}/man3/Apache*
This page took 0.082112 seconds and 4 git commands to generate.