]> git.pld-linux.org Git - packages/perl-QWizard.git/blob - perl-QWizard.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-QWizard.git] / perl-QWizard.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    QWizard
6 Summary:        QWizard - Display a series of questions, get the answers, and act on the answers
7 Summary(pl.UTF-8):      QWizard - wyświetlanie serii pytań, pobranie odpowiedzi i ich obsługa
8 Name:           perl-QWizard
9 Version:        3.15
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/QWizard/QWizard-%{version}.tar.gz
15 # Source0-md5:  e5cf695466d39ad6c7f242ad58b7ad97
16 URL:            http://search.cpan.org/dist/QWizard/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 QWizard displays a list of grouped questions, and retrieves and
24 processes user-specified answers to the questions. Multiple
25 question/answer sets may be displayed before the answers are dealt
26 with. Once a "commit" action is taken (instigated by the user), a
27 series of actions is performed to handle the answers. The actions are
28 executed in the order required by the QWizard programmer.
29
30 QWizard's real power lies in its inherent ability to keep track of all
31 state information between one wizard screen and the next, even in
32 normally stateless transaction environments like HTTP and HTML. This
33 allows a QWizard programmer to collect a large body of data with a
34 number of simple displays. After all the data has been gathered and
35 verified, then it can be handled as appropriate (e.g., written to a
36 database, used for system configuration, or used to generate a graph.)
37
38 Current user interfaces that exist are HTML, Gtk2, Tk, and (minimally)
39 ReadLine. A single QWizard script implementation can make use of any
40 of the output formats without code modification. Thus it is extremely
41 easy to write portable wizard scripts that can be used without
42 modification by both graphical window environments (Gtk2 and Tk) and
43 HTML-based web environments (e.g., CGI scripts.), as well with
44 intercative command line enviornments (ReadLine).
45
46 %description -l pl.UTF-8
47 QWizard wyświetla listę pogrupowanych pytań, a następnie pobiera i
48 przetwarza odpowiedzi użytkownika. Przed obsługą odpowiedzi może być
49 wyświetlonych wiele pytań/odpowiedzi. Po zatwierdzeniu całości (z
50 udziałem użytkownika) wykonywana jest seria akcji - w kolejności
51 wymaganej przez programistę.
52
53 Prawdziwa siła QWizarda polega na możliwości śledzenia informacji o
54 stanie między jednym ekranem kreatora a następnym, nawet w zwykle
55 bezstanowych środowiskach, takich jak HTTP i HTML. Pozwala to
56 programiście zebrać duży zestaw danych z wielu prostych ekranów. Po
57 zebraniu wszystkich danych i zweryfikowaniu ich, można je odpowiednio
58 obsłużyć (np. zapisać w bazie danych, użyć do konfiguracji systemu
59 albo do wygenerowania wykresu).
60
61 Aktualnie istniejące interfejsy użytkownika to HTML, Gtk2, Tk oraz
62 (minimalnie) ReadLine. Prosta implementacja skryptów QWizarda może
63 wykorzystywać dowolny z formatów wyjściowych bez modyfikowania kodu.
64 Dzięki temu bardzo łatwo napisać przenośne skrypty kreatorów, które
65 można bez żadnej modyfikacji wykorzystywać w środowiskach graficznych
66 (Gtk2 i Tk) oraz środowiskach WWW opartych na HTML-u (np. skryptach
67 CGI), a także interaktywnych środowiskach tekstowych (ReadLine).
68
69 %prep
70 %setup -q -n %{pdir}-%{version}
71
72 %build
73 %{__perl} Makefile.PL \
74         INSTALLDIRS=vendor
75 %{__make}
76
77 %{?with_tests:%{__make} test}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} pure_install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/QWizard_Widgets.pod
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc CHANGES README
96 %{perl_vendorlib}/QWizard.pm
97 %{perl_vendorlib}/QWizard
98 %attr(755,root,root) %{perl_vendorlib}/QWizard_Widgets.pl
99 %dir %{perl_vendorlib}/auto/QWizard
100 %dir %{perl_vendorlib}/auto/QWizard/Generator
101 %{perl_vendorlib}/auto/QWizard/Generator/autosplit.ix
102 %{_mandir}/man3/QWizard*.3pm*
103 %{_examplesdir}/%{name}-%{version}
This page took 0.11111 seconds and 3 git commands to generate.