]> git.pld-linux.org Git - packages/perl-Proc-ProcessTable.git/blob - perl-Proc-ProcessTable.spec
perl 5.38.0 rebuild
[packages/perl-Proc-ProcessTable.git] / perl-Proc-ProcessTable.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test" (requires mounted /proc)
4
5 %define         pdir    Proc
6 %define         pnam    ProcessTable
7 Summary:        Proc::ProcessTable - Perl interface to the UNIX process table
8 Summary(pl.UTF-8):      Proc::ProcessTable - interfejs perlowy do uniksowej tabeli procesów
9 Name:           perl-Proc-ProcessTable
10 Version:        0.59
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Proc/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3330a3648eeaad54d19a091742a2ac5a
17 URL:            http://search.cpan.org/dist/Proc-ProcessTable/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module is a first crack at providing a consistent interface to
24 Unix (and maybe other multitasking OS's) process table information.
25 The impetus for this came about with my frustration at having to parse
26 the output of various systems' ps commands to check whether specific
27 processes were running on different boxes at a larged mixed UNIX site.
28 The output format of ps was different on each OS, and sometimes
29 changed with each new release of an OS. Also, running a ps subprocess
30 from within a perl or shell script and parsing the output was not a
31 very efficient or aesthetic way to do things.
32
33 %description -l pl.UTF-8
34 Ten moduł to pierwsza próba udostępnienia spójnego interfejsu do
35 informacji dotyczących uniksowej (i może z innych wielozadaniowych
36 systemów operacyjnych) tabeli procesów. Impuls do stworzenia tego
37 pojawił się wraz z frustracją autora przy analizie wyjścia poleceń ps
38 z różnych systemów w celu sprawdzenia, czy określone procesy działają
39 na różnych maszynach w dużym zestawie różnych Uniksów. Format wyjścia
40 ps był różny na każdym systemie, a czasem zmieniał się wraz z nową
41 wersją systemu. Poza tym uruchamianie procesu ps z Perla lub skryptu
42 powłoki i analiza jego wyjścia nie były zbyt wydajnym ani estetycznym
43 sposobem.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README README.linux Changes
68 %dir %{perl_vendorarch}/Proc
69 %{perl_vendorarch}/Proc/*.pm
70 %{perl_vendorarch}/Proc/ProcessTable
71 %dir %{perl_vendorarch}/auto/Proc
72 %dir %{perl_vendorarch}/auto/Proc/ProcessTable
73 %attr(755,root,root) %{perl_vendorarch}/auto/Proc/ProcessTable/*.so
74 %{perl_vendorarch}/auto/Proc/ProcessTable/Process
75 %{_mandir}/man3/Proc::Killall.3pm*
76 %{_mandir}/man3/Proc::Killfam.3pm*
77 %{_mandir}/man3/Proc::ProcessTable*
This page took 0.119185 seconds and 4 git commands to generate.