]> git.pld-linux.org Git - packages/perl-Proc-Background.git/blob - perl-Proc-Background.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Proc-Background.git] / perl-Proc-Background.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Proc
6 %define         pnam    Background
7 Summary:        Proc::Background Perl module - generic interface to background process management
8 Summary(pl.UTF-8):      Moduł Perla Proc::Background - ogólny interfejs do zarządzania procesami w tle
9 Name:           perl-Proc-Background
10 Version:        1.10
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  4f9d850e31c4131d1a28ffe0d26ef4e2
17 URL:            http://search.cpan.org/dist/Proc-Background/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Provides:       perl(Proc::Generic)
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Proc::Background Perl module is a generic interface for placing
26 processes in the background on Unix platforms. This module lets you
27 start, kill, wait on, retrieve exit values, and see if background
28 processes still exist.
29
30 %description -l pl.UTF-8
31 Moduł Perla Proc::Background stanowi podstawowy interfejs dla
32 umieszczania procesów w tle na platformach uniksowych. Moduł ten
33 umożliwia uruchamianie, zabijanie procesów, oczekiwanie na ich
34 zakończenie i odbieranie kodu powrotu procesu. Za jego pomocą można
35 też zobaczyć, jakie procesy nadal działają w tle.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %attr(755,root,root) %{_bindir}/timed-process
60 %{perl_vendorlib}/Proc/Background.pm
61 %dir %{perl_vendorlib}/Proc/Background
62 %{perl_vendorlib}/Proc/Background/Unix.pm
63 #%%{perl_vendorlib}/Proc/Background/Win32.pm
64 %{_mandir}/man1/*
65 %{_mandir}/man3/Proc::Background.*
66 %{_mandir}/man3/Proc::Background::Unix*
67 #%%{_mandir}/man3/Proc::Background::Win32*
This page took 0.084639 seconds and 3 git commands to generate.