]> git.pld-linux.org Git - packages/perl-Pod-Tests.git/blob - perl-Pod-Tests.spec
- updated to 1.20
[packages/perl-Pod-Tests.git] / perl-Pod-Tests.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Pod
6 %define         pnam    Tests
7 Summary:        Pod::Tests - Extracts embedded tests and code examples from POD
8 Summary(pl.UTF-8):      Pod::Tests - wydobywanie osadzonych testów i przykładowego kodu z POD
9 Name:           perl-Pod-Tests
10 Version:        1.20
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Pod/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5f1c6b7423f660869323396176619fd8
17 URL:            https://metacpan.org/release/Pod-Tests
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 %if %{with tests}
20 BuildRequires:  perl-Test-Harness >= 1.22
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 3.0.3-16
25 BuildRequires:  rpmbuild(macros) >= 1.745
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a specialized POD viewer to extract embedded tests and code
31 examples from POD. It doesn't do much more than that. pod2test does
32 the useful work.
33
34 %description -l pl.UTF-8
35 Ten pakiet jest specjalizowaną przeglądarką POD służącą do wyciągania
36 osadzonych testów i przykładowego kodu z dokumentacji w formacie POD.
37 Robi niewiele więcej. pod2test wykonuje przydatną czynność.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %attr(755,root,root) %{_bindir}/pod2test
62 %{perl_vendorlib}/Pod/Tests.pm
63 %{_mandir}/man1/pod2test.1p*
64 %{_mandir}/man3/Pod::Tests.3pm*
This page took 0.083832 seconds and 4 git commands to generate.