]> git.pld-linux.org Git - packages/perl-Pod-Strip.git/blob - perl-Pod-Strip.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Pod-Strip.git] / perl-Pod-Strip.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Pod
6 %define pnam    Strip
7 Summary:        Pod::Strip - Remove POD from Perl code
8 Summary(pl.UTF-8):      Pod::Strip - usuwanie POD z kodu perlowego
9 Name:           perl-Pod-Strip
10 Version:        1.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Pod/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b5ac7b0e68d8d44bd737f1ba71aaee3f
17 URL:            http://search.cpan.org/dist/Pod-Strip/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Pod-Simple >= 3.00
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Pod::Strip is a subclass of Pod::Simple that strips all POD from Perl
29 code.
30
31 %description -l pl.UTF-8
32 Pod::Strip to podklasa Pod::Simple usuwająca całą dokumentację POD z
33 kodu perlowego.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Build.PL \
40         destdir=$RPM_BUILD_ROOT \
41         installdirs=vendor
42 ./Build
43
44 %{?with_tests:./Build test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 ./Build install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README TODO
57 %{perl_vendorlib}/Pod/Strip.pm
58 %{_mandir}/man3/Pod::Strip.3pm*
This page took 0.045085 seconds and 4 git commands to generate.