]> git.pld-linux.org Git - packages/perl-Pod-Parser.git/blob - perl-Pod-Parser.spec
- updated to 1.66
[packages/perl-Pod-Parser.git] / perl-Pod-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Pod
6 %define         pnam    Parser
7 Summary:        Pod::Parser - base class for creating POD filters and translators
8 Summary(pl.UTF-8):      Pod::Parser - klasa bazowa do tworzenia klas filtrujących i tłumaczących POD
9 Name:           perl-Pod-Parser
10 Version:        1.66
11 Release:        1
12 Epoch:          1
13 # I'm not sure how to interpret the README...
14 License:        Artistic
15 Group:          Development/Languages/Perl
16 Source0:        https://www.cpan.org/modules/by-module/Pod/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c1d20031bc2b75ea0fe7bf6d313b1d30
18 URL:            https://metacpan.org/dist/Pod-Parser
19 BuildRequires:  perl(File::Spec) >= 0.82
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-Test-Simple >= 0.60
25 %endif
26 # podselect used to be bundled in perl-tools-pod
27 Conflicts:      perl-tools-pod < 1:5.32
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32   This parrot is dead. It has ceased to be.
33   It's gone to meet it's Maker! THIS IS AN EX-PARROT!
34     -- The Dead Parrot Sketch, Monty Python's Flying Circus
35
36 Do s/parrot/package/g and you know the status of this distribution.
37
38 Pod::Parser is a base class for creating POD filters and translators.
39 It handles most of the effort involved with parsing the POD sections
40 from an input stream, leaving subclasses free to be concerned only
41 with performing the actual translation of text.
42
43 Pod::Parser parses PODs, and makes method calls to handle the various
44 components of the POD. Subclasses of Pod::Parser override these
45 methods to translate the POD into whatever output format they desire.
46
47 %description -l pl.UTF-8
48   Ta papuga jest martwa. Przestała istnieć.
49   Odeszła na spotkanie ze swoim stwórcą! TO JEST EX-PAPUGA!
50     -- skecz "Martwa Papuga", Latający Cyrk Monty Pythona
51
52 Wykonaj s/papuga/pakiet/g, a poznasz status tego modułu.
53
54 Pod::Parser to klasa bazowa do tworzenia klas filtrujących i
55 tłumaczących POD. Obsługuje większą część zadań związanych z analizą
56 sekcji POD ze strumienia wejściowego, pozostawiając podklasom jedynie
57 przeprowadzanie samego tłumaczenia tekstu.
58
59 Pod::Parser przetwarza pliki POD i wywołuje metody obsługujące różne
60 komponenty POD. Podklasy Pod::Parser przykrywają te metody w celu
61 tłumaczenia POD na żądany format wyjściowy.
62
63 %prep
64 %setup -q -n %{pdir}-%{pnam}-%{version}
65
66 %build
67 %{__perl} Makefile.PL \
68         INSTALLDIRS=vendor
69 %{__make}
70
71 %{?with_tests:%{__make} test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CHANGES README TODO
85 %attr(755,root,root) %{_bindir}/podselect
86 %{perl_vendorlib}/Pod/Find.pm
87 %{perl_vendorlib}/Pod/InputObjects.pm
88 %{perl_vendorlib}/Pod/ParseUtils.pm
89 %{perl_vendorlib}/Pod/Parser.pm
90 %{perl_vendorlib}/Pod/PlainText.pm
91 %{perl_vendorlib}/Pod/Select.pm
92 %{_mandir}/man1/podselect.1p*
93 %{_mandir}/man3/Pod::Find.3pm*
94 %{_mandir}/man3/Pod::InputObjects.3pm*
95 %{_mandir}/man3/Pod::ParseUtils.3pm*
96 %{_mandir}/man3/Pod::Parser.3pm*
97 %{_mandir}/man3/Pod::PlainText.3pm*
98 %{_mandir}/man3/Pod::Select.3pm*
This page took 0.104846 seconds and 4 git commands to generate.