]> git.pld-linux.org Git - packages/perl-PerlIO-gzip.git/blob - perl-PerlIO-gzip.spec
perl 5.38.0 rebuild
[packages/perl-PerlIO-gzip.git] / perl-PerlIO-gzip.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    PerlIO
6 %define         pnam    gzip
7 Summary:        PerlIO::gzip - Perl extension to provide a PerlIO layer to gzip/gunzip
8 Summary(pl.UTF-8):      PerlIO::gzip - rozszerzenie perla dostarczające warstwę PerlIO do operacji gzip/gunzip
9 Name:           perl-PerlIO-gzip
10 Version:        0.18
11 Release:        15
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/N/NW/NWCLARK/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  933fdf283a0d2739f7630420569e3b24
17 Patch0:         config_usesfio.patch
18 URL:            http://search.cpan.org/dist/PerlIO-gzip/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 PerlIO::gzip provides a PerlIO layer that manipulates files in the
25 format used by the gzip program. Compression and Decompression are
26 implemented, but not together. If you attempt to open a file for
27 reading and writing the open will fail.
28
29 %description -l pl.UTF-8
30 PerlIO::gzip dostarcza wartstwę PerlIO, która potrafi operować na
31 plikach w formatach używanych przez program gzip.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35 %patch0 -p1
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/PerlIO/*.pm
59 %dir %{perl_vendorarch}/auto/PerlIO/gzip
60 %attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/gzip/*.so
61 %{_mandir}/man3/*
This page took 0.0946 seconds and 3 git commands to generate.