]> git.pld-linux.org Git - packages/perl-Perl6-Junction.git/blob - perl-Perl6-Junction.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Perl6-Junction.git] / perl-Perl6-Junction.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Perl6
6 %define pnam    Junction
7 Summary:        Perl6::Junction - Perl6 style Junction operators in Perl5
8 Summary(pl.UTF-8):      Perl6::Junction - operatory Junction w stylu Perl6 dla Perl5
9 Name:           perl-Perl6-Junction
10 Version:        1.40000
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/C/CF/CFRANKS/Perl6-Junction-%{version}.tar.gz
16 # Source0-md5:  0d94cc39ac646175ad38451ef752e982
17 URL:            http://search.cpan.org/dist/Perl6-Junction/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is a lightweight module which provides 'Junction' operators, the
25 most commonly used being any and all.
26
27 Inspired by the Perl6 design docs,
28 http://dev.perl.org/perl6/doc/design/exe/E06.html.
29
30 Provides a limited subset of the functionality of
31 Quantum::Superpositions, see /"SEE ALSO" for comment.
32
33 Notice in the /SYNOPSIS above, that if you want to match against a
34 regular expression, you must use == or !=. Not =~ or !~. You must also
35 use a regex object, such as qr/\d/, not a plain regex such as /\d/.
36
37 # %description -l pl.UTF-8
38 # TODO
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %dir %{perl_vendorlib}/Perl6
63 %{perl_vendorlib}/Perl6/*.pm
64 %{perl_vendorlib}/Perl6/Junction
65 %{_mandir}/man3/*
This page took 0.071995 seconds and 4 git commands to generate.