]> git.pld-linux.org Git - packages/perl-Path-Tiny.git/blob - perl-Path-Tiny.spec
- updated to 0.122
[packages/perl-Path-Tiny.git] / perl-Path-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Path
6 %define         pnam    Tiny
7 Summary:        Path::Tiny - File path utility
8 Summary(pl.UTF-8):      Path::Tiny - narzędzia do ścieżek plików
9 Name:           perl-Path-Tiny
10 Version:        0.122
11 Release:        1
12 License:        Apache v2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/D/DA/DAGOLDEN/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  f746d8da5d049a5523b1880666bb0992
16 URL:            https://metacpan.org/release/Path-Tiny
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl(Exporter) >= 5.57
23 BuildRequires:  perl(File::Path) >= 2.07
24 BuildRequires:  perl(File::Spec) >= 0.86
25 BuildRequires:  perl-Digest >= 1.03
26 BuildRequires:  perl-Digest-MD5
27 BuildRequires:  perl-Digest-SHA >= 5.45
28 BuildRequires:  perl-Encode
29 BuildRequires:  perl-File-Temp >= 0.19
30 BuildRequires:  perl-Test-Simple >= 0.96
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This module provides a small, fast utility for working with file
37 paths. It is friendlier to use than File::Spec and provides easy
38 access to functions from several other core file handling modules. It
39 aims to be smaller and faster than many alternatives on CPAN, while
40 helping people do many common things in consistent and less
41 error-prone ways.
42
43 %description -l pl.UTF-8
44 Ten moduł zawiera małe, szybkie narzędzie do pracy ze ścieżkami
45 plików. Jest bardziej przyjazny w użyciu niż File::Spec i daje łatwy
46 dostęp do funkcji z kilku innych głównych modułów obsługujących pliki.
47 Moduł ma za zadanie być mniejszym i szybszym od alternatyw z CPAN-u,
48 pomagając ludziom wykonywać wiele popularnych zadań w spójny i
49 bardziej błędoodporny sposób.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} pure_install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes
73 %{perl_vendorlib}/Path/Tiny.pm
74 %{_mandir}/man3/Path::Tiny.3pm*
This page took 0.1028 seconds and 4 git commands to generate.