]> git.pld-linux.org Git - packages/perl-Parse-PMFile.git/blob - perl-Parse-PMFile.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Parse-PMFile.git] / perl-Parse-PMFile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Parse
6 %define         pnam    PMFile
7 Summary:        Parses .pm file as PAUSE does
8 Name:           perl-Parse-PMFile
9 Version:        0.36
10 Release:        1
11 License:        GPL+ or Artistic
12 Group:          Development/Libraries
13 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  102f1901c15e1b1458b74eb4278558e8
15 URL:            http://search.cpan.org/dist/Parse-PMFile/
16 BuildRequires:  perl(JSON::PP) >= 2.00
17 BuildRequires:  perl(version) >= 0.83
18 BuildRequires:  perl-ExtUtils-MakeMaker-CPANfile
19 %if %{with tests}
20 BuildRequires:  perl(File::Temp) >= 0.19
21 BuildRequires:  perl(Test::More) >= 0.88
22 BuildRequires:  perl-version
23 %endif
24 Requires:       perl(JSON::PP) >= 2.00
25 Requires:       perl(version) >= 0.83
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The most of the code of this module is taken from the PAUSE code as of
31 April 2013 almost verbatim. Thus, the heart of this module should be
32 quite stable. However, I made it not to use pipe ("-|") as well as I
33 stripped database related code. If you encounter any issue, that's
34 most probably because of my modification.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 find $RPM_BUILD_ROOT -type f -name .packlist | xargs rm -v
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Parse/PMFile.pm
59 %{_mandir}/man3/Parse::PMFile.3pm*
This page took 0.08909 seconds and 4 git commands to generate.