]> git.pld-linux.org Git - packages/perl-Params-ValidationCompiler.git/blob - perl-Params-ValidationCompiler.spec
- macros for perl autodeps
[packages/perl-Params-ValidationCompiler.git] / perl-Params-ValidationCompiler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Params
6 %define         pnam    ValidationCompiler
7 Summary:        Params::ValidationCompiler - Build an optimized subroutine parameter validator once, use it forever
8 Summary(pl.UTF-8):      Params::ValidationCompiler - tworzenie zoptymalizowanego walidatora parametrów raz do wielokrotnego użycia
9 Name:           perl-Params-ValidationCompiler
10 Version:        0.30
11 Release:        1
12 License:        Artistic v2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Params/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  f7746a98cab3d7a246372379d4658a4e
16 URL:            https://metacpan.org/release/Params-ValidationCompiler
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 %if %{with tests}
21 BuildRequires:  perl-Eval-Closure
22 BuildRequires:  perl-Exception-Class
23 BuildRequires:  perl-Scalar-List-Utils >= 1.29
24 BuildRequires:  perl-Specio >= 0.14
25 BuildRequires:  perl-Test-Simple >= 1.302015
26 BuildRequires:  perl-Test-Without-Module
27 BuildRequires:  perl-Test2-Plugin-NoWarnings
28 BuildRequires:  perl-Test2-Suite >= 0.000106
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This is very alpha. The module name could change. Everything could
35 change. You have been warned.
36
37 Create a customized, optimized, non-lobotomized, uncompromised, and
38 thoroughly specialized parameter checking subroutine.
39
40 %description -l pl.UTF-8
41 Ten moduł jest w głębokim stanie alfa - nazwa może się zmienić;
42 wszystko może się zmienić. To ostrzeżenie.
43
44 Tworzenie dostosowanych, zoptymalizowanych, bezkompromisowych i
45 szczegółowo wyspecjalizowanych procedur sprawdzających parametry.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes
72 %{perl_vendorlib}/Params/ValidationCompiler.pm
73 %{perl_vendorlib}/Params/ValidationCompiler
74 %{_mandir}/man3/Params::ValidationCompiler*.3pm*
75 %{_examplesdir}/%{name}-%{version}
This page took 0.06536 seconds and 4 git commands to generate.