]> git.pld-linux.org Git - packages/perl-Parallel-Iterator.git/blob - perl-Parallel-Iterator.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Parallel-Iterator.git] / perl-Parallel-Iterator.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Parallel
6 %define pnam    Iterator
7 Summary:        Parallel::Iterator - Simple parallel execution
8 Summary(pl.UTF-8):      Parallel::Iterator - proste zrównoleglenie wykonywania
9 Name:           perl-Parallel-Iterator
10 Version:        1.00
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Parallel/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  879051d329ea79f59eb4b03bb0bf7c87
17 URL:            http://search.cpan.org/dist/Parallel-Iterator/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Requires:       perl-dirs >= 2.1-19
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The map function applies a user supplied transformation function to
27 each element in a list, returning a new list containing the
28 transformed elements.
29
30 This module provides a 'parallel map'. Multiple worker processes are
31 forked so that many instances of the transformation function may be
32 executed simultaneously.
33
34 For time consuming operations, particularly operations that spend most
35 of their time waiting for I/O, this is a big performance win. It also
36 provides a simple idiom to make effective use of multi CPU systems.
37
38 %description -l pl.UTF-8
39 Funkcja map wykonuje zadane przez użytkownika przekształcenie na
40 każdym elemencie listy, zwracając nową listę zawierającą
41 przekształcone elementy.
42
43 Ten moduł udostępnia równogległą wersję tej funkcji. Uruchamiane jest
44 wiele procesów, co pozwala na jednoczesne wykonywanie wielu instancji
45 funkcji przekształcenia.
46
47 Dla czasochłonnych operacji, w szczególności takich, przy których
48 większość to oczekiwanie na we/wy, daje to duży zysk wydajnościowy.
49 Moduł także udostępnia prosty idiom, pozwalający efektywnie
50 wykorzystać systemy wieloprocesorowe.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Build.PL \
57         destdir=$RPM_BUILD_ROOT \
58         installdirs=vendor
59 ./Build
60
61 %{?with_tests:./Build test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 ./Build install
66
67 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorlib}/Parallel/Iterator.pm
77 %{_mandir}/man3/Parallel::Iterator.3pm*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.116144 seconds and 4 git commands to generate.