]> git.pld-linux.org Git - packages/perl-PadWalker.git/blob - perl-PadWalker.spec
perl 5.38.0 rebuild
[packages/perl-PadWalker.git] / perl-PadWalker.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %define         pdir    PadWalker
6 Summary:        PadWalker - play with other peoples' lexical variables
7 Summary(pl.UTF-8):      PadWalker - igranie z cudzymi zmiennymi leksykalnymi
8 Name:           perl-PadWalker
9 Version:        2.5
10 Release:        3
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/R/RO/ROBIN/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  f3f1e06c0385aab80353176a414f02b2
16 URL:            https://metacpan.org/release/PadWalker
17 BuildRequires:  perl-ExtUtils-MakeMaker
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 PadWalker is a Perl module which allows you to inspect (and even
25 change!) lexical variables in any subroutine which called you. It will
26 only show those variables which are in scope at the point of the call.
27
28 %description -l pl.UTF-8
29 PadWalker jest modułem Perla umożliwiającym przeglądanie (a nawet
30 modyfikacje!) zmiennych leksykalnych w dowolnej wywołanej funkcji.
31 Pokazuje on tylko te zmienne, których zasięg obejmuje miejsce
32 wywołania.
33
34 %prep
35 %setup -q -n %{pdir}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/PadWalker.pm
59 %dir %{perl_vendorarch}/auto/PadWalker
60 %attr(755,root,root) %{perl_vendorarch}/auto/PadWalker/PadWalker.so
61 %{_mandir}/man3/PadWalker.3pm*
This page took 0.087866 seconds and 3 git commands to generate.