]> git.pld-linux.org Git - packages/perl-Package-Variant.git/blob - perl-Package-Variant.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Package-Variant.git] / perl-Package-Variant.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Package
6 %define         pnam    Variant
7 Summary:        Package::Variant - Parameterizable packages
8 #Summary(pl.UTF-8):     
9 Name:           perl-Package-Variant
10 Version:        1.002000
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Package/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fc0b756835c26d6d6dca711021fb94c0
17 URL:            http://search.cpan.org/dist/Package-Variant/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Import-Into >= 1
22 BuildRequires:  perl-Module-Runtime >= 0.013
23 BuildRequires:  perl-strictures >= 1
24 BuildRequires:  perl-Test-Fatal
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module allows you to build packages that return different
31 variations depending on what parameters are given.
32
33 Users of your package will receive a subroutine able to take
34 parameters and return the name of a suitable variant package.
35 The implementation does not care about what kind of package it builds.
36
37 There are two important parts to creating a variable package. You
38 first have to give Package::Variant some basic information about what
39 kind of package you want to provide, and how. The second part is
40 implementing a method receiving the user's arguments and generating
41 your variants.
42
43 # %description -l pl.UTF-8
44 # TODO
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorlib}/Package/Variant.pm
69 %{_mandir}/man3/*
This page took 0.067278 seconds and 4 git commands to generate.