]> git.pld-linux.org Git - packages/perl-Package-Stash-XS.git/blob - perl-Package-Stash-XS.spec
- updated URL
[packages/perl-Package-Stash-XS.git] / perl-Package-Stash-XS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Package
6 %define         pnam    Stash-XS
7 Summary:        Package::Stash::XS - faster and more correct implementation of the Package::Stash API
8 Summary(pl.UTF-8):      Package::Stash::XS - szybsza i bardziej poprawna implementacja API Package::Stash
9 Name:           perl-Package-Stash-XS
10 Version:        0.30
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Package/Package-Stash-XS-%{version}.tar.gz
16 # Source0-md5:  40ff29b53c91cbc9d5ff5d31cb161c6e
17 URL:            https://metacpan.org/dist/Package-Stash-XS
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Test-Fatal
24 BuildRequires:  perl-Test-Needs
25 BuildRequires:  perl-Test-Simple >= 0.88
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a backend for Package::Stash, which provides the functionality
31 in a way that's less buggy and much faster. It will be used by default
32 if it's installed, and should be preferred in all environments with a
33 compiler.
34
35 %description -l pl.UTF-8
36 Ten moduł jest backendem dla modułu Package::Stash, udostępniającym
37 jego funkcjonalność w mniej błędny i szybszy sposób. Jest używany jako
38 domyślny backend jeśli jest zainstalowany i powinien być preferowany
39 we wszystkich środowiskach z kompilatorem.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %dir %{perl_vendorarch}/Package
66 %dir %{perl_vendorarch}/Package/Stash
67 %{perl_vendorarch}/Package/Stash/XS.pm
68 %dir %{perl_vendorarch}/auto/Package
69 %dir %{perl_vendorarch}/auto/Package/Stash
70 %dir %{perl_vendorarch}/auto/Package/Stash/XS
71 %attr(755,root,root) %{perl_vendorarch}/auto/Package/Stash/XS/XS.so
72 %{_mandir}/man3/Package::Stash::XS.3pm*
This page took 0.162823 seconds and 4 git commands to generate.